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1    Hotfix 5059.001 (15.06.2022) | User

1.1    Hotfix 5059.001 | Introduction

Dear SwissSalary Customers,

Dear SwissSalary Partners,

We present to you the manual for SwissSalary Hotfix 5059.001 of June 15, 2022. Your SwissSalary will be up to

date after installing this update. 

IMPORTANT NOTES

qBasic requirement
Please make sure that a version not older than 5059.000 is installed before running the update process. If
your Dynamics 365 has implemented company-specific changes to your SwissSalary standard objects, you
must contact your Dynamics 365 partner prior to installing the objects.
Please make sure that you always work with the latest version. We support the latest and most
recent SwissSalary version.

qComprehensive update with all available objects
The main updates will be released in April/May and October/November similar to the Microsoft Dynamics
365 Business Central release cycle. Each individual version must be installed chronologically. No update
versions may be omitted (except hotfixes). The client must be restarted after the installation of each version
for the update process to run and the latest version to appear under ‘Organization’.

SwissSalary 365 | Microsoft Dynamics 365 Business Central | Microsoft SaaS-Cloud

The SwissSalary 365 app is always up-to-date with the latest versions of Microsoft Dynamics 365 Business

Central and SwissSalary. The app is updated with just a few clicks directly via the admin center (see our video

tutorial). Starting from the 5057.000 release, the video is also displayed directly in the Role Center under

Product Videos.

https://www.youtube.com/watch?v=Le5o_pxsh6w&t=14s
https://www.youtube.com/watch?v=Le5o_pxsh6w&t=14s
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qSwissSalary onPrem | Dynamics 365 Business Central
SwissSalary Update 5059.001 is available for the Business Central versions below (onPrem/private cloud):

o new Dynamics 365 Business Central 2022 Wave 2 – version 21 (AL)
o Dynamics 365 Business Central 2022 Wave 1 – version 20 (AL)
o Dynamics 365 Business Central 2021 Wave 2 – version 19 (AL)
o Dynamics 365 Business Central 2021 Wave 1 – version 18 (AL)
o Dynamics 365 Business Central Spring’ 19 – version 14 (C/AL)
o Dynamics 365 Business Central Fall’ 18 – version 13 (C/AL)

The new ‘AL’ versions of Dynamics 365 Business Central are controlled by the new Microsoft life cycle

concept. We support the latest version. This concerns, for example, the next version 5060.000 to be released

in autumn 2022:

o new Dynamics 365 Business Central 2022 Wave 2 - version 21 (October 2022)
o Dynamics 365 Business Central 2022 Wave 1 - version 20 (April 2022) 

‘Dynamics 365 Business Central 2020 Wave 2 - version 17 (AL)’ will no longer be supported as of Update
5058.000!
Please update your solution to Business Central 2022 Wave 1 - Version 20 as soon as possible!

qSwissSalary onPrem | Dynamics NAV
SwissSalary Update 5059.001 is available for the following Dynamics NAV versions (onPrem/private cloud):
o Dynamics NAV 2018
o Dynamics NAV 2017

qSwissSalary BAU Customers
Customers using SwissSalary BAU solution receive this update for ‘Dynamics 365 Business Central Spring' 19
- Version 14 (C/AL)’ only. Older versions are no longer supported.

qWithholding tax rates, ZIP codes and bank master data, and SwissSalary default permissions (roles)
Please always stay up to date. SwissSalary regularly publishes the latest rates and master data in SwissSalary
Store. This data can be updated via Organization with just one click. Also, you can update now just individual
WT rates for a canton.

qRole Center
SwissSalary Role Center | RTC Clients starting from Dynamics NAV 2013 up to Business Central Spring’ 19 -
Version 14 (C/AL)
Since the introduction of the RTC Client, SwissSalary has been using a clearly arranged and intuitive Role
Center. System Administrator Manual contains important information thereto.

We hope you will enjoy the latest version of SwissSalary and thank you for the valuable improvement

suggestions we could implement for you.

Your SwissSalary Team
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1.2    Interfaces

1.2.1    SAP Interface | Posting date error

Task #11509 | 5059.001

Beginning from the last update 5059.000, there has been an error in the interface to SAP Business by Design
preventing the salary from being posted on the SwissSalary side. The transmission to SAP worked at all times
and led to multiple entries in SAP after several attempts. SwissSalary has now introduced a correction and the
posting can be made in one step.

1.3    KLE

1.3.1    KLE | Calculation of the 13th MW Hourly salary

Task #11501 | 5059.001

A correction had to be made during the calculation of the 13th monthly wage for hourly wage recipients with
immediate payment so that the values are not taken into account twice in the UKA interface and KLE
(electronic accident and illness reports).

1.4    Administration

1.4.1    Payroll Setup | KLE and SUA contact

Task #11512 | 5059.001

If the “Delegate” field in Swissdec settings is filled with a company contact (company name and address), the
UID BFS-No. must be entered. The last name and first name of a contact person are no longer required.
This is the case when a company has commissioned a trustee agency. Otherwise, it can remain empty.

1.5    Payroll

1.5.1    Payment order | QR invoice integrated

Task #11483 | 5059.001

If bank details with the QR invoice payment method were entered for employees, this payment was missing in

the “Payment order (summarized)” report.  This has been corrected and the Payment order (summarized)

report now shows the same total as the Payment order (detailed) report.

1.6    Employee

1.6.1    TimeMachine | Department

Task #11491 | 5059.001
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No selection list of the stored departments could be retrieved for the Department field in TimeMachine. This
bug has been fixed.

1.6.2    TimeMachine | linked fields

Task #11481 | 5059.001

When a TimeMachine value was entered in the Employee card – tab Salary (e.g. Salary amount), the linked
fields (e.g. Salary rate) were not updated or set to 0.00. This bug has been fixed and TimeMachine works
perfectly again.

1.6.3    Direct registration Code | Suppression on Payslip

Task #11448 | 5059.001

A new field “Suppress SwissSalary Direct registration code” has been added in the Employee card in the
General tab. If this field is active, the registration code will not be displayed on the payslip. This field can also be
viewed in the pay process list, edited and changed for the desired pay process. 

1.6.4    Employee Card | Semi Families

Task #11472 | 5059.001

A test was rolled out with update 5059.000 as part of Swissdec 5.0. The single-parent family selection was
linked to the Concubinage field. This was corrected. 
When a IT rate is selected, the selection must be made in the Semi Families field. The selection is based on the
requirements of the Swissdec guidelines. If this is the case, the selection for common-law spouse can also be
set to ‘yes’. Even then, a selection must be made for single-parent family.
The inclusion in the IT transfer takes place after implementation and certification according to Swissdec 5.0. 
To provide support in checking the rate classification, we have published FAQs under Single-parent families
FAQ. 

1.6.5    Employee list | Status filter triggers errors

Task #11505 | 5059.001

The filter automatically set for the status blocked the search for employees in the Employee list in French. We
were able to fix this by removing brackets in the translation.

1.6.6    Employee templates | Allocation Group filter

Task #11418 | 5059.001

The Allocation Group filter now also applies to Employee templates.

1.6.7    Employee templates | Personnel dimensions

Task #11417 | 5059.001

https://www.swisssalary.ch/faq#Definition-Halbfamilien
https://www.swisssalary.ch/faq#Definition-Halbfamilien
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New personnel dimensions can be stored in the Employee template provided during the creation of new
employees.

1.7    EasyRapport

1.7.1    EasyRapport | Corss-client license validation

Task #11490 | 5059.001

With user restrictions for clients, an error message occurred during data import because the license validation
could not be carried out correctly due to missing access privileges. 
Cross-client validation has been improved. As a user, you do not need to take any action. 
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2    Hotifx 5059.001 (15.06.2022) | Systemadmin

2.1    SwissSalary-Homepage | Objects and app download

I work in SaaS cloud from Microsoft Dynamics 365 Business Central (online). Do I have to download the objects
from the website and install?

No. 
You will only find on our website the objects and apps for the installed versions (onPremise). You can update
your app directly within the SaaS solution. 
We continuously check customer-specific adjustments (so-called PTE, per-tenant extensions) before each
update. They should be available as usual without any further steps at your end, even after the update, and you
do not need to update them. 

How is SwissSalary customer area accessed (SwissSalary onPrem customers and partners only)?

Go to our website at https://swisssalary.ch Click Login at the top right.
Log in using your company-specific login data (email). Then click the Update NAV button (SwissSalary BC/NAV
customers) or the Update BAU button (SwissSalary BAU customers).

You will be offered the latest Updates and Hotfixes for download (SwissSalary onPrem).

Which documents can you additionally download?

In addition to the latest Update, the latest Hotfixes (if any) can be downloaded and installed in SwissSalary. This
way, your object status will always be up to date (recommended).

The library of current manuals and further information about SwissSalary is constantly updated, expanded and
published at https://docs.swisssalary.ch.

We have also created a helpful reference portal in the form of the SwissSalary Frequently Asked Questions
(FAQ) page, which we continue to expand.

How is a file downloaded from the Internet?

Click the corresponding icon with your mouse and the download starts (you will find the file under
“Downloads”):

Will I be informed about improvements to SwissSalary?

We use different communication channels, e.g. Yammer (SwissSalary Partner Network), via newsletters,
website and via news in the Role Center.

Do you have questions about our website or downloading?

https://www.youtube.com/watch?v=Le5o_pxsh6w
https://swisssalary.ch
https://docs.swisssalary.ch
https://www.swisssalary.ch/faq
https://www.swisssalary.ch/faq
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Please contact your Dynamics 365 partner, email us at support@swisssalary.ch or call our hotline +41 (0)31 /
950 07 77. We will be pleased to advise you!

2.2    Importing/updating Updates and Hotfixes

These explanations only concern customers with installed versions (onPremise).

1. Download the objects according to the descriptions in the previous chapter.

IMPORTANT NOTES:
qThe User Manual can be found at https://docs.swisssalary.ch.
qMake sure that update version B5059.000 (BAU) / N5059.000 (BC/NAV) or later is installed on your system.

Check this in SwissSalary in RTC client under Role Center -> Organization.
qPlease check with your Dynamics 365 partner whether you have made any custom adjustments. They would

be lost after an update without prior backup.

IF A VERSION EARLIER THAN B5059.000 / N5059.000 IS INSTALLED, THEN INTERRUPT THE INSTALLATION AND
NOTIFY YOUR PARTNER OR US!

TIP:
We recommend that you make a backup before the update. It is usually unnecessary, but makes sense for
security reasons.

2. Unzip the app/object file using WinZip.

3. Open Dynamics 365 Business Central / Microsoft Dynamics NAV and switch to the Object Designer by
pressing Shift+F12 (Extras -> Object Designer).

You can see now all objects available for you in the BC/NAV database.

4. Go to File -> Import.

5. Enter the path to your saved APP/FOB file. The system will try now to import the file.

6. You will see info now that MUST be confirmed with OK or No.

NOTE:
ALWAYS open the import worksheet!

7. The import worksheet will open.

IMPORTANT NOTE:
It is IMPERATIVE that you click REPLACE ALL here! Finally, click OK to continue the import process!

The following message also appears in the RTC client (starting from NAV 2015) (confirm it by selecting “Force”):

Synchronization is automatically requested in the RTC client (starting from NAV 2015), please confirm this
message with YES:

8. The objects are now imported into your database. After a successful installation, you will get the following
completion message: 

mailto:support@swisssalary.ch
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IMPORTANT NOTES:

We recommend that you compile the SwissSalary objects after import (F11). Please set a filter (F7) in the
version list to SwS* and make sure that “All” is selected on the left-hand side. Please note that it is preferable to
restart the BC/NAV service. As a rule, only the administrator with relevant permissions can do it (please execute
during off-hours only when no users are logged in anymore).

IMPORTANT:
We do NOT provide any app import support in the onPrem environment. Please directly contact your
Dynamics 365 partner for the installation of your BC 17 or BC 18 version.

9. Update Process

After a successful import of the objects, please switch to the SwissSalary main menu or Role Center.

Click the Personnel menu item (Personnel card). The system begins the update process automatically. A
person with administrator rights should only open the main Update menu. Otherwise, the update will fail.
Once the process is completed successfully, you will receive a completion message.

You will find an update history under Role Center -> Organization where all successfully imported update
versions are logged.

The update process must be performed after every Update / Hotfix.

In the Excel table, you will see the objects that have been newly created or modified. These can be found
together with Objects in the protected partner area on our website. 

Explanation of the types:

1 = Table
3 = Report
4 = Dataport
5 = Codeunit
6 = XMLport
7 = MenuSuite
8 = Page
9 = Query

If you have any questions, please contact your Dynamics 365 partner or our support directly.These

explanations only concern customers with installed versions (onPremise).

1. Download the objects according to the descriptions in the previous chapter.

IMPORTANT NOTES:
qThe User Manual can be found at https://docs.swisssalary.ch.
qMake sure that update version B5059.000 (BAU) / N5059.000 (BC/NAV) or later is installed on your system.

Check this in SwissSalary in RTC client under Role Center -> Organization.
qPlease check with your Dynamics 365 partner whether you have made any custom adjustments. They would

be lost after an update without prior backup.
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IF A VERSION EARLIER THAN B5057.000 / N5057.000 IS INSTALLED, THEN INTERRUPT THE INSTALLATION AND
NOTIFY YOUR PARTNER OR US!

TIP:
We recommend that you make a backup before the update. It is usually unnecessary, but makes sense for
security reasons.

2. Unzip the app/object file using WinZip.

3. Open Dynamics 365 Business Central / Microsoft Dynamics NAV and switch to the Object Designer by
pressing Shift+F12 (Extras -> Object Designer).

You can see now all objects available for you in the BC/NAV database.

4. Go to File -> Import.

5. Enter the path to your saved APP/FOB file. The system will try now to import the file.

6. You will see info now that MUST be confirmed with OK or No.

NOTE:
ALWAYS open the import worksheet!

7. The import worksheet will open.

IMPORTANT NOTE:
It is IMPERATIVE that you click REPLACE ALL here! Finally, click OK to continue the import process!

The following message also appears in the RTC client (starting from NAV 2015) (confirm it by selecting “Force”):

Synchronization is automatically requested in the RTC client (starting from NAV 2015), please confirm this
message with YES:

8. The objects are now imported into your database. After a successful installation, you will get the following
completion message: 

IMPORTANT NOTES:

We recommend that you compile the SwissSalary objects after import (F11). Please set a filter (F7) in the
version list to SwS* and make sure that “All” is selected on the left-hand side. Please note that it is preferable to
restart the BC/NAV service. As a rule, only the administrator with relevant permissions can do it (please execute
during off-hours only when no users are logged in anymore).

IMPORTANT:
We do NOT provide any app import support in the onPrem environment. Please directly contact your
Dynamics 365 partner for the installation of your BC 17 or BC 18 version.

9. Update Process

After a successful import of the objects, please switch to the SwissSalary main menu or Role Center.

Click the Personnel menu item (Personnel card). The system begins the update process automatically. A
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person with administrator rights should only open the main Update menu. Otherwise, the update will fail.
Once the process is completed successfully, you will receive a completion message.

You will find an update history under Role Center -> Organization where all successfully imported update
versions are logged.

The update process must be performed after every Update / Hotfix.

In the Excel table, you will see the objects that have been newly created or modified. These can be found
together with Objects in the protected partner area on our website. 

Explanation of the types:

1 = Table
3 = Report
4 = Dataport
5 = Codeunit
6 = XMLport
7 = MenuSuite
8 = Page
9 = Query

If you have any questions, please contact your Dynamics 365 partner or our support directly.

2.3    Access Rights and Permissions

Permission roles description:

Group ID Name Description

SWS-ALL SwissSalary –
All Users

The only user role that must be assigned to every SwissSalary user.
The “Wage Accounting Process” feature requires that the system should
obtain “indirect” information about all clients (license check, how many
employees are currently accounted for in the entire database. Of course, the payroll
staff member cannot see any data of the restricted clients).

SWS-CONS /
SWS
INVOICING
(SwissSalary
BAU only)

SwissSalary -
Consortium
SwissSalary -
Invoicing

This role is used for working in the ARGE module. This permission role allows
full access to ARGE items and ARGE posting journals. This role is suitable for
employees that are only allowed to operate ARGE in payroll accounting.

SWS-EE-EDIT SwissSalary –
Edit
Employees

This role is the classical assignment for payroll staff members that need to use
all features of payroll accounting. The user can edit, delete, enter data in
SwissSalary; however s/he cannot change payroll master data.

SWS-EE READ SwissSalary –
Read
Employees

Similar to the SWS-EE EDIT role, with the exception that data can be viewed
only, and not changed (read-only rights).

SWS-HR EDIT SwissSalary –
HR Edit
Employee

PIS (Personal Information System) add-on module. A user with this role can
modify, delete and enter data in PIS. 



Seite 14

SWS-HR READ SwissSalary –
HR Read
Employee

PIS (Personal Information System) add-on module. Read-only rights.

SWS-HR SETUP SwissSalary –
HR Setup

PIS (Personal Information System) add-on module. A user with this role can
change settings in PIS. Classical HR wage administrator.

SWS-POST
(SwissSalary
NAV only)

SwissSalary –
Posting

In accordance with the SOX guidelines, payroll staff member is not allowed to
'post wages'.
This user role can be assigned to an employee in the FIBU that is exclusively
responsible for wage posting.
IMPORTANT: Of course, this employee must be also activated in SwissSalary
under Company -> Settings -> Users or in the RTC version under SwissSalary
Administration -> Users.

SWS-SETUP SwissSalary –
Setup

Classical authorization role for wage administrator

SWS-SETUP-
LIGHT

SwissSalary -
Setup Light

Same authorization as SWS-SETUP with the restriction that no changes can be
made to the SwissSalary User

SWS-ST EDIT SwissSalary –
Edit Salary
Type

Full access for editing wage types. A user with this role can create, modify and
delete wage types.

SWS-BUDGET-
EDIT

SwissSalary
Budget - Edit

This role is used to create budget structures, FTE budgets, budgets in amounts
and forecasts.

SWS-BUDGET-
READ

SwissSalary
Budget -
Read

This role is used to read budget structures, FTE budgets, budgets in amounts
and forecasts.

SWS-BUDGET-
SETUP

SwissSalary
Budget -
Setup

This role is used for setup in the SwissSalary Budget module. Classical
authorization role for wage administrators

SWS-KLE EDIT SwissSalary
KLE – Edit

KLE cases can be edited with this role. If this role is assigned, the SWS-EE-EDIT
role or SWS-EE-READ role must also be assigned.

After each Update/PreUpdate the modified permission roles must be adjusted in SwissSalary (new tables
access, etc.)

IMPORTANT NOTE:
qIf you made individual adjustments in the Default “SWS-*” permission roles, please bear in mind that they are

overwritten with the automatic import of the “default” roles.
qBe sure to add these new tables to the relevant permission roles before releasing the system for the users!

The import process for default roles is started via Role Center-> Organization. Here you can “Install all Store
updates” with a single click:

In case of customer-specific roles, select relevant path for the ZIP file in the Options tab and choose Import
under Direction. Then click OK, default user roles are adjusted in SwissSalary.

If you made changes to our default user roles or want to manually maintain user roles, you can do so below or
under Extras -> Security -> Roles. Click the relevant role and add the new tables under Role -> Access rights. This
setting can be found in the RTC client under Departments -> Administration -> IT administration -> General ->
Sets of rights. If you have any questions about these settings, contact the partner responsible for you.
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The tables below have been rebuilt and must be added to the relevant roles (if already used and for companies
that do not work with default permissions):

SwissSalary Role Center
Each BC-/NAV module has its own role center. For this purpose, SwissSalary has developed the SwS Payroll Role
Center. We recommend that you work with this role center in the area of wages. You can also import the role
center (XML file is included with the update objects).
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